Antwort schreiben 
 
Themabewertung:
  • 0 Bewertungen - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Aktivierungscode für Steuergerät Einspritzanlage
Verfasser Nachricht
swolf Offline
Junior Member
**

Beiträge: 11
Registriert seit: May 2015
Bewertung 0
Bedankte sich: 0
0x gedankt in 0 Beiträgen
Beitrag #1
Aktivierungscode für Steuergerät Einspritzanlage
Liebe Gemeinde,

unser Twingo, Bj Mitte 99, hat die WFS in der Dachkonsole. Der IR-Dekoder tut was er soll - Türen gehen auf und zu, die WFS-Leuchte geht aus, aber der Motor springt nicht an. Das passierte in den letzten Monaten erst nur gelegentlich, dann mit der FB nochmal auf und zu und dann gings wieder. Wichtig dabei: es ist nicht die WFS, die den Motor nach einer Sekunde wieder abschaltet, nein, es gibt gar keine Zündung, also auch kein kurzes Starten und wieder ausgehen (das ist tritt ja auf, wenn die WFS abschaltet). Die WFS zeigt auch keine Sperrfunktion an der Kontrollleuchte an.

Da der Fehler langsam immer häufiger auftrat, lag es nahe, über verbrannte Relaiskontakte nachzudenken (Halbleiter sind entweder in Ordnung oder defekt, bei Relais jedoch kann sich ein langsames Sterben der Lastkontakte bemerkbar machen wegen zunehmender Verzunderung). Habe das Relais auf der WFS-Platine mit Kontaktspray behandelt - funktionierte dann auch einige Tage tadellos. Leider ist der alte Fehler erneut aufgetreten und nun so, dass auch nach x-mal auf-zu-Schaltung keine Aktivierung der Einspritzanlage mehr erfolgt.

Jetzt würde mich interessieren, wie die codierte Kommunikation zwischen WFS und Einspritzanlage aussieht und wie ich am Einspritz-Steuergerät einen Kommunikationsfehler mit der WFS erkennen kann? Auch die Schaltung der WFS-Platine wäre von großem Interesse. Zur Verdeutlichung hab ich zwei Bilder angehängt: das Blockschaltbild der WFS und ein Foto der ausgebauten WFS.

[Bild: twingo-30235301-9Gw.jpg]

Das Relais hab ich ausgelötet, um es zu ersetzen - nur ist das ein Spezialteil, das man nicht so ohne Weiteres bekommt. Deshalb hab ich's erstmal mit ein paar Leitungen wieder verbunden. Und hier die Schaltung: die spannende Frage ist, was genau passiert an Kommunikation auf der farbig markierten Leitung:

[Bild: twingo-30235535-rDY.jpg]

Vielleicht habt ihr ja einen Plan zu dem Thema - die Fragen noch mal zusammengefasst:

- Schaltplan WFS-Platine
- Freigabeprotokoll WFS-Einspritzsteuerung
- wie Einspritzsteuerung auf Zustand aktiviert/deaktiviert prüfen

Danke schon mal fürs MitgrübelnWink

Grüsse
Werner
30.05.2015 23:08
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
Broadcasttechniker Offline
Ulli mit 2 "L"
******

Beiträge: 25.364
Registriert seit: May 2007
Bewertung 119
Bedankte sich: 4486
4723x gedankt in 3889 Beiträgen
Beitrag #2
RE: Aktivierungscode für Steuergerät Einspritzanlage
Da brauche ich nicht grübeln.
Das Relais ist immer unschuldig, selbst wenn es kaputt wäre.
Ich sehe auch eine weggebrannte Leiterbahn, die wird mit deinem Problem nichts zu tun haben.
Die Kommunikation mit dem Steuergerät läuft über eine einzige Leitung und zum Glück nicht über CAN, sonst wärst du gearscht.

Ich mache es kurz: Besorge dir einen Fremddekoder und einen Emulator.
Schalte dein Steuergerät in den virgin mode und baue den Emulator ein.
ZV machst du dann über Funk.
Grundlegendes http://www.twingotuningforum.de/thread-6230.html
Speziell Phase2 (deine), leider noch nicht fertig http://www.twingotuningforum.de/thread-34515.html
Funk ZV, bitte nach meinen Beiträgen im Thread schauen http://www.twingotuningforum.de/thread-28939.html
Ja, jetzt hast du was zu lesen.

Geteiltes Wissen ist doppeltes Wissen
30.05.2015 23:38
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Mein Twingo Diese Nachricht in einer Antwort zitieren nach oben
swolf Offline
Junior Member
**

Beiträge: 11
Registriert seit: May 2015
Bewertung 0
Bedankte sich: 0
0x gedankt in 0 Beiträgen
Beitrag #3
RE: Aktivierungscode für Steuergerät Einspritzanlage
(30.05.2015 23:38)Broadcasttechniker schrieb:  Da brauche ich nicht grübeln.
Das Relais ist immer unschuldig, selbst wenn es kaputt wäre.
...es schaltet eben nur die Türaktoren und nicht die Leitung zur Einspritzsteuerung...tja, hätte ich mal früher wissen müssen;-(

(30.05.2015 23:38)Broadcasttechniker schrieb:  Ich sehe auch eine weggebrannte Leiterbahn, die wird mit deinem Problem nichts zu tun haben.
Die Kommunikation mit dem Steuergerät läuft über eine einzige Leitung und zum Glück nicht über CAN, sonst wärst du gearscht.
...das war ein kleines Missgeschick beim in-circuit-testingWink - das gelbe Kabel ist dafür da, den Schaden zu behebenWink...


(30.05.2015 23:38)Broadcasttechniker schrieb:  Ich mache es kurz: Besorge dir einen Fremddekoder und einen Emulator.
Schalte dein Steuergerät in den virgin mode und baue den Emulator ein.
ZV machst du dann über Funk.
Grundlegendes http://www.twingotuningforum.de/thread-6230.html
Speziell Phase2 (deine), leider noch nicht fertig http://www.twingotuningforum.de/thread-34515.html
Funk ZV, bitte nach meinen Beiträgen im Thread schauen http://www.twingotuningforum.de/thread-28939.html
Ja, jetzt hast du was zu lesen.

ok, ganz herzlichen Dank, das zieh' ich mir jetzt erstmal rein...

noch eine Randbemerkung: der uProzessor der WFS hat laut Spec nur CMOS und ROM Speicher - kein EEPROM oder Flash, d.h. er muss seine Rolling-Codes extern speichern. Dazu dient wahrscheinlich das EEPROM auf der Karte. Würde man also das EEPROM auf eine andere WFS verpflanzen (was für mich die geringste Hürde darstellt), so müsste rein theoretisch alles wieder funktionieren. Nur für den Fall, daß WFS und Einspritz-Steuergerät einen festen Code miteinander haben (der also nicht aus dem Rolling Code generiert wird), gibt es ein Problem beim Wechseln der WFS-Platine...ist aber alles reine Theorie!

Also erstmal ganz herzlichen Dank für die Hinweise,

wir kriegen das Baby schon zum LaufenWink

Gruss
Werner
31.05.2015 00:07
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
Broadcasttechniker Offline
Ulli mit 2 "L"
******

Beiträge: 25.364
Registriert seit: May 2007
Bewertung 119
Bedankte sich: 4486
4723x gedankt in 3889 Beiträgen
Beitrag #4
RE: Aktivierungscode für Steuergerät Einspritzanlage

Geteiltes Wissen ist doppeltes Wissen
31.05.2015 00:35
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Mein Twingo Diese Nachricht in einer Antwort zitieren nach oben
Twingz Offline
Member
***

Beiträge: 132
Registriert seit: May 2015
Bewertung 0
Bedankte sich: 3
20x gedankt in 17 Beiträgen
Beitrag #5
RE: Aktivierungscode für Steuergerät Einspritzanlage
Kann auch kalte Lötstelle sein, da , wo die Anschlusskabel auf die Platine gehen.
31.05.2015 05:29
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
swolf Offline
Junior Member
**

Beiträge: 11
Registriert seit: May 2015
Bewertung 0
Bedankte sich: 0
0x gedankt in 0 Beiträgen
Beitrag #6
RE: Aktivierungscode für Steuergerät Einspritzanlage
(31.05.2015 05:29)Twingz schrieb:  Kann auch kalte Lötstelle sein, da , wo die Anschlusskabel auf die Platine gehen.

glaub ich eher nicht, da die Kabel von mir dran gemacht wurden, nachdem ich das Relais ausgelötet hatte (ich hatte angenommen, das Relais ist der Übeltäter, isses aber nicht). Ansonsten sind alles Steckkontakte an der WFS-Platine und die Lötstellen sehen durchweg professionell aus - maschinell gelötet. Aber prinzipiell kann das sporadische Auftreten des Fehlers natürlich auch mit einer schlechten Lötstelle zu tun haben.

Danke für die Anregung,

Grüsse
Werner
31.05.2015 08:39
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
Harald_K Offline
Posting Freak
*****

Beiträge: 2.983
Registriert seit: Feb 2011
Bewertung 11
Bedankte sich: 44
718x gedankt in 577 Beiträgen
Beitrag #7
RE: Aktivierungscode für Steuergerät Einspritzanlage
schau dir wegen kalter Lötstellen einfach mal diese an - bemerkst du einen feinen zackigen dunklen Ring um den durchgesteckten Bauteildraht, dann ist da was faul. Tritt nach meiner Erfahrung zwar bei doppleseitig durchkontaktierten Platinen nur selten auf, kommt aber durchaus vor.
Bevorzugte Teile für sowas: alles, was groß, schwer oder weit herausstehend ist. (Vibrationsrisse)
Bei der WFS-Platine würd ich das Relais, den Stecker, den blauen Elko und die Kontakte des IR-Empfängers verdächtigen - wobei die Leitungen zum Empfänger auch direkt am Empfängergehäuse brechen können.

Zum Schaltplan - den kann man doch selber machen, ist ja kaum was drauf.
Zu deinen Beschriftungen käme noch ein Stabi (hinter dem blauen Elko), ein Relaistreiber(ULN... oder so, der DIL14/16 hinterm Proz) und vermutlich ein IR-Vorverstärker neben dem Empfängerkasten dazu - denke aber mal daß dir das nix bringt, weil die Kommunikation ohne Kenntnis des Programmes im µC oder nem guten Logikanalysator / Speicheroszi und reichlich Hirnschmalz kaum rauszubekommen sein wird.

tschüss,

Harald_K
31.05.2015 09:40
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
Broadcasttechniker Offline
Ulli mit 2 "L"
******

Beiträge: 25.364
Registriert seit: May 2007
Bewertung 119
Bedankte sich: 4486
4723x gedankt in 3889 Beiträgen
Beitrag #8
RE: Aktivierungscode für Steuergerät Einspritzanlage
So oder so, der Reparaturansatz heißt: Fremddekoder besorgen oder leihen, hier im Forum haben den einige, ich zähle dazu.
Motorsteuergerät jungfräulich machen und nicht aus Versehen neu codieren.
Wenn doch ist das auch kein Beinbruch weil rückgängig zu machen.
WFS Emulator Dongle einbauen.
Wenn du Komfort willst, Funk einbauen.

Geteiltes Wissen ist doppeltes Wissen
31.05.2015 09:49
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Mein Twingo Diese Nachricht in einer Antwort zitieren nach oben
swolf Offline
Junior Member
**

Beiträge: 11
Registriert seit: May 2015
Bewertung 0
Bedankte sich: 0
0x gedankt in 0 Beiträgen
Beitrag #9
RE: Aktivierungscode für Steuergerät Einspritzanlage
Wir haben deutliche Fortschritte gemacht - eure Hinweise und links sind Gold wert: wenn man sich in die ganze Thematik ein bischen eingelesen hat, sieht man dann auch bald den Silberstreifen am Horizont:

habe über Nacht die Batterie abgeklemmt, Stecker vom WFS-Modul abgezogen, dann Batterie angeklemmt, dann Modulstecker wieder aufgesteckt und siehe da: WFS und Einspritzsteuerung mögen sich wiederWink ich kanns kaum glauben...
Sie tut auch alles, was sie soll: sperrt bei geschlossenem Fahrzeug oder auch nach 10 Minuten bei offenem Fahrzeug.

Nur eins tut sie nicht: die rote LED der WFS ist aus - und zwar total aus, kein Piepser mehr...find ich aber nicht so wichtig.

Für mich die entscheidende Frage ist: was hat die beiden Steuergeräte veranlasst, wieder miteinander zu reden? Da kann vielleicht der BreitbandSendeTechnikerWink was zu sagen? Ist es möglich, daß das Einspritzsteuergerät beim booten auf Horchposten geht, wenn keine WFS gefunden wird, und wenn die dann aktiv wird (durch Steckerverbinder aufstecken) den Code neu übernimmt? (alles nur Vermutungen, habe leider keine technische Information zu den Protokollen finden können).

Bin heute bestimmt 20 mal am Auto gewesen um zu testen: hat immer alles funktioniert...habe das ausgelötete Relais erstmal nur lose in die Dachschale reingelegt und werde das jetzt erst einmal weiter beobachten.

Eine Sache hat mich aber doch schon verwundert: ich hab ja den Deckel vom Relais aufgeschnitten, um da mal nachzusehen, ob die Schaltkontakte verzundert sind. Und was soll ich sagen: beide Schaltgruppen (ZV-auf und ZV-zu) ziehen einen wunderbaren Funken beim Abschalten. Nach ein paar hundert oder tausend Schaltungen sind die Kontakte definitiv hin. Das weiss aber doch jeder Erstsemester E-Technik, daß man Induktivitäten (das sind die Türaktoren) nicht einfach abschalten kann, ohne wenigstens eine Freilaufdiode zu spendieren - aber dafür hat der Geldbeutel bei Renault wohl nicht gereicht - vielleicht soll's auch einfach nur zeitig ausfallen;-(( Die Methode ist auf jeden Fall zielführendWink

soweit jm2c
Gruss
Werner
31.05.2015 22:13
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
Broadcasttechniker Offline
Ulli mit 2 "L"
******

Beiträge: 25.364
Registriert seit: May 2007
Bewertung 119
Bedankte sich: 4486
4723x gedankt in 3889 Beiträgen
Beitrag #10
RE: Aktivierungscode für Steuergerät Einspritzanlage
Keine Sorge, die Relais gehen nicht kaputt.
Was mit einiger Sicherheit wieder ausfallen wird ist die Kommunikation.
Du bist gewarnt, wenn du nicht handelst wirst du bald wieder stehen.
Mit kaputter Diode auch keine Notfallcodeeingabe möglich....
Schau mal ob der Dauerplus an deinem Lampenbrett dran ist, der speist nur diese Diode.

Geteiltes Wissen ist doppeltes Wissen
31.05.2015 22:31
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Mein Twingo Diese Nachricht in einer Antwort zitieren nach oben
swolf Offline
Junior Member
**

Beiträge: 11
Registriert seit: May 2015
Bewertung 0
Bedankte sich: 0
0x gedankt in 0 Beiträgen
Beitrag #11
RE: Aktivierungscode für Steuergerät Einspritzanlage
(31.05.2015 22:31)Broadcasttechniker schrieb:  Keine Sorge, die Relais gehen nicht kaputt.
Was mit einiger Sicherheit wieder ausfallen wird ist die Kommunikation.

..das fürchte ich auch;-(

(31.05.2015 22:31)Broadcasttechniker schrieb:  Du bist gewarnt, wenn du nicht handelst wirst du bald wieder stehen.
Mit kaputter Diode auch keine Notfallcodeeingabe möglich....
Schau mal ob der Dauerplus an deinem Lampenbrett dran ist, der speist nur diese Diode.

...die Notfalleingabe brauch ich ja nicht: die entriegelt nur die WFS - das tut aber doch alles perfekto - das Problem ist die Kommunikation mit dem Einspritz-Steuergerät - und da ist mir immer noch nicht klar, was eigentlich auf der markierten Leitung im Schaltplan passiert: ist das eine definierte Schnittstelle (z.B. RS232) oder irgend ein geheimes Renault-Gezumpel und welches Protokoll läuft da eigentlich? Verdaxxt - warum hat die Kiste keinen CAN-Bus oder wenigstens eine OBDII - dann könnte man da mal etwas genauer reinseh'n Wink

Werde noch mal deinem Hinweis zum Dauerplus nachgehen...kann ein paar Tage dauern (Twingo ist heute Abend auf Reisen gegangen - ich bin gespannt, wann der Anruf kommt: 'der Motor springt nicht an - was soll ich tun?') - Gott bewahre!!

Grüsse und herzlichen Dank für die Infos,
Werner
31.05.2015 23:02
Alle Beiträge dieses Benutzers finden Diese Nachricht in einer Antwort zitieren nach oben
Broadcasttechniker Offline
Ulli mit 2 "L"
******

Beiträge: 25.364
Registriert seit: May 2007
Bewertung 119
Bedankte sich: 4486
4723x gedankt in 3889 Beiträgen
Beitrag #12
RE: Aktivierungscode für Steuergerät Einspritzanlage
Werner, du bist dir der Brisanz der Problematik überhaupt nicht bewusst.
Und Verstanden hast du nichts.
(31.05.2015 23:02)swolf schrieb:  ...die Notfalleingabe brauch ich ja nicht: die entriegelt nur die WFS...
Entriegelt nur die WFS?
Nur?
Bei Ausfall der WFS stehst du.
WFS steht für Wegfahrsperre, der wichtigste Teil davon steckt im Motorsteuergerät
Ich gebe zu, ich habe verdammt viel geschrieben und es ist schwer alles zusammen zu suchen.
Daher hier nochmal.
Der Dekoder schickt dem Steuergerät ständig Worte sobald die Zündung an ist.
Bekommt das Steuergerät kein gültiges Wort (Dekder ab, kaputt oder ohne Saft) springt der Motor nicht an.
Bekommt es ein Sperrwort (Dekoder ist im Sperrzustand) springt der Motor nicht an.
Obwohl diese Worte recht lang sind (32bit) ist das meiste Synchrongedöns, es gibt nur einige 1000 gültige Codes.
Die Übertragung ist schneckenlahm, ein Wort braucht ca. 0,5 Sekunden für die Übertragung, das ist also in etwa TELEX Niveau.
Bei WFS mit CAN bist du übrigens ziemlich gearscht, ein Emulator dafür kostet immer noch richtig Geld.
Selbst die CAN Twingo 1 benutzen zum Glück für die WFS eine extra Codeleitung, daher kannst du dir für 15€ einen Emulator anschließen.

Nochmals, dein Auto hat dir netterweise eine Warnung geschickt, wenn du die ignorierst stehst du begossen da und keiner kann dir helfen, noch nicht einmal Renault.
Dann kannst du dir bei Pavel ein freies Steuergerät kaufen, im Tausch gegen deines, aber das geht auch nicht an einem Tag.

Geteiltes Wissen ist doppeltes Wissen
31.05.2015 23:45
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden Mein Twingo Diese Nachricht in einer Antwort zitieren nach oben
Antwort schreiben 


Möglicherweise verwandte Themen...
Thema: Verfasser Antworten: Ansichten: Letzter Beitrag
  Auto geht in Notprogramm, Fehleranzeige Einspritzanlage GoKarter 5 2.652 08.12.2015 12:22
Letzter Beitrag: Broadcasttechniker
  Warnleuchte "Einspritzanlage" leuchtet, Fehlerspeicher Null Fehler!? mlauten 3 2.118 23.11.2015 15:02
Letzter Beitrag: Waschi
ZZTwingo1 WARNLEUCHTE ELEKRTRONIK STEUERGERÄT EINSPRITZANLAGE Butsher 11 14.249 19.12.2011 11:19
Letzter Beitrag: Butsher
  Einspritzanlage Warnleuchte blinkt wenn Motor an! French Racing 7 5.187 13.06.2010 10:40
Letzter Beitrag: Twingolove
  Störung der Elektrischen Einspritzanlage star_buck 1 2.812 16.09.2009 11:26
Letzter Beitrag: Broadcasttechniker
  Steuergerät Einspritzanlage hin ... was nun? scenicforum 6 2.983 10.05.2007 20:19
Letzter Beitrag: scenicforum
  Einspritzanlage Warnleuchte blinkt Twingo69 10 6.905 07.10.2002 16:10
Letzter Beitrag: Twingo69

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste

Kontakt | TwingoTuningForum.de | Nach oben | Zum Inhalt | Mobile Version | RSS-Synchronisation